Mailtarget Dashboard Status Update

Incident Report for Mailtarget Status

Resolved

The issue has been resolved, all systems are back to normal.
Posted Feb 10, 2026 - 22:09 WIB

Investigating

Our monitoring system has detected an issue affecting Mailtarget Dashboard.
Our team is currently investigating the cause.
Posted Feb 10, 2026 - 21:59 WIB
This incident affected: Mailtarget Dashboard.